Components versions

The following table lists the components versions of the Cluster release 5.16.0.

Note

The components that are newly added, updated, deprecated, or removed as compared to the previous release version, are marked with a corresponding superscript, for example, lcm-ansible Updated.

Components versions of the Cluster release 5.16.0

Component

Application/Service

Version

Cluster orchestration

Mirantis Kubernetes Engine

3.3.6 0

Container runtime

Mirantis Container Runtime

19.03.14 1

Distributed storage

Ceph

14.2.19 (Nautilus)

Rook

1.5.9

LCM

descheduler

0.8.0

Helm

2.16.11-40

helm-controller Updated

0.2.0-349-g4870b7f5

lcm-ansible Updated

0.7.0-9-g30acaae

lcm-agent Updated

0.2.0-349-g4870b7f5

metallb-controller

0.9.3-1

metrics-server

0.3.6-1

StackLight

Alerta

8.4.1-20210312131419

Alertmanager

0.21.0

Alertmanager Webhook ServiceNow

0.1-20210426114325

Cerebro

0.9.3

Elasticsearch Updated

7.10.2-20210513065347

Elasticsearch curator

5.7.6

Elasticsearch exporter

1.0.2

Fluentd Updated

1.10.2-20210518100631

Grafana

7.5.4

Grafana Image Renderer

2.0.1

IAM Proxy

6.0.1

Kibana Updated

7.10.2-20210513065546

Metric Collector

0.1-20210219112938

Metricbeat Updated

7.10.2

Netchecker Deprecated

1.4.1

Patroni Updated

13-2.0p6-20210525081943

Prometheus

2.22.2

Prometheus Blackbox Exporter

0.14.0

Prometheus ES Exporter

0.5.1-20210323132924

Prometheus MS Teams

1.4.2

Prometheus Node Exporter

1.0.1

Prometheus NGINX Exporter

0.6.0

Prometheus Patroni Exporter

0.1-20200428121305

Prometheus Postgres Exporter Updated

0.9.0

Prometheus Relay

0.3-20210317133316

Pushgateway

1.2.0

sf-notifier

0.3-20210323132354

sf-reporter

0.1-20201216142628

Telegraf

1.9.1-20210225142050

Telemeter

4.4.0-20200424

0

For the MKE release highlights and components versions, see MKE documentation: MKE release notes.

1
  • For the MCR release highlights, see MCR documentation: MCR release notes.

  • Due to the development limitations, the MCR upgrade to version 19.03.14 on existing Container Cloud clusters is not supported.